January 16th, 2007 at 12:19 am

WP 2.0.7 and Advanced Search 0.5

WordPress 2.0.7 has just been released. It fixes a security hole which allowed to read the WordPress database via the file wp-trackback.php. Although the threat depends on special circumstances and does not apply to all WordPress sites, it is highly recommended to update as soon as possible.

On a related note, there’s a new version of the Advanced Search plugin available. An error with category filtering on blogs with only one author reported by cj has been fixed in the new version. Also, there is now an Italian translation thanks to Andrea Barbieri.

The plugin is as always available from its home page. Have fun with the new version and let me know how you like it. Also, please help out with translations, and report bugs as well as improvement ideas!

Update: There was still another bug occuring on blogs with several authors of which only one actually has posts. The problem was fixed and the download for 0.5 was updated. Thanks to solemnchaos for the hint.

2 Comments

  1. Klaus · February 21st, 2007 at 5:19 pm #

    Hallo Alex,

    erhalte folgende Fehlermeldung unter den Suchergebnissen im advanced search formular.

    SELECT category_nicename AS original, sanitised FROM wp_categories c INNER JOIN wp_cat2syn syn ON c.cat_ID = syn.cat_id WHERE c.category_nicename IN (‘allgemein’) AND syn.language_id =

    Fuer jeden Tip dankbar.

    Herzliche Gruesse

    Klaus

  2. Klaus · February 25th, 2007 at 11:17 am #

    Hallo Alex,

    herzlichen Dank fuer Deine Info. Habe advanced search 06 installiert ( auf wp 2.0.8 ). Es laeuft einwandfrei.

    Viele Gruesse

    Klaus

Leave a Comment